Kết quả 1 đến 3 của 3
  1. #1
    CI New VnZacky's Avatar
    Ngày tham gia
    19-07-2013
    Bài viết
    10
    Cảm ơn
    1
    Được cảm ơn 2 trong 2 bài viết

    [HELP] Lỗi khi load giao diện???

    Hôm trước thì code run ok.
    Nhưng tối qua mới move 1 số file sang module khác thì gặp phải tình cảnh này:

    PHP Code:
    function __construct()
        {
            
    parent::__construct();
            
    $this->load->model(array('account','order_m'));
            
    $this->load->helper('home');
            if(
    $this->my_auth->is_Login()) {
                
    $this->uid $this->session->userdata('u_id');
                
    $this->user $this->account->get_user($this->uid);
                if(
    $this->user['active'] == 0)
                {
                    
    $data['sub_temp']   =   '404';
                    
    $data['error']  =   "1";
                    
    $this->load->view('cart/cart_temp'$data);
                    return 
    TRUE;
                }
            }
        }
        
        
        function 
    index()
        {
            if(!
    $this->my_auth->is_Login()) {
                
    $this->login();
            } else {
                
    $this->profile();
            }
        }
        
        
    /**
         * Profile 
         */
        
    function profile()
        {
            if(!
    $this->my_auth->is_User()) {
                
    $this->login();
            } else {
                
    $data['user']   =   $this->user;
                
    $this->load->view('user_temp',$data);
            }
        } 
    Khi construct được load thì sẽ kiểm tra "acc chưa active" thì sẽ load ra file báo lỗi.
    Nhưng 1 điều là là nó vẫn load thêm view của profile mặc dù khi check error ở construct mình đã return cho nó dừng lại rồi.
    Và ở đây khi nó gọi hàm profile thì nó lại nhận luôn 2 giá trị sau mặc dù 2 biến đó được var tại construct:
    PHP Code:
    $data['sub_temp']   =   '404';
    $data['error']  =   "1"

    Mong ae giúp đỡ. Cảm ơn
    Sửa lần cuối bởi VnZacky; 18-03-2014 lúc 10:42 AM.

  2. #2
    CI New VnZacky's Avatar
    Ngày tham gia
    19-07-2013
    Bài viết
    10
    Cảm ơn
    1
    Được cảm ơn 2 trong 2 bài viết
    Ai có thể teamview xem hộ tớ với :(
    Giờ vẫn chưa hiểu được vấn đề nó là sao cả.
    Ai help mong add skype: vnzacky39

  3. #3
    Moderator vudesign's Avatar
    Ngày tham gia
    23-01-2014
    Bài viết
    324
    Cảm ơn
    22
    Được cảm ơn 45 trong 39 bài viết
    Bạn đưa thông báo lỗi lên cho mọi người cùng tham khảo nào

Chia sẽ và Bình Luận chủ đề [HELP] Lỗi khi load giao diện??? trên facebook

Các Chủ đề tương tự

  1. Code mới hoàn thành anh em nhận xét vào giao lưu.
    Bởi truongnguyenhd trong diễn đàn Hỏi đáp
    Trả lời: 2
    Bài cuối: 15-05-2014, 05:55 AM
  2. Hỏi cách tạo CKEDITOR giao diện như diễn đàn codeigniter.vn
    Bởi PhanNguyenChuong trong diễn đàn Hỏi đáp
    Trả lời: 0
    Bài cuối: 04-08-2013, 06:12 PM

Các từ khóa xuất hiện trên google của chủ đề

Chưa có từ khóa lên top google

Tag của Chủ đề này - Hãy Thêm Tags Để bài viết nhanh lên top google

Quyền viết bài

  • Bạn không thể đăng chủ đề mới
  • Bạn không thể gửi trả lời
  • Bạn không thể gửi đính kèm
  • Bạn không thể sửa bài
  •